Data Replication Delay

Incident Report for Snapsheet

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 07:45 CDT

Monitoring

We have resolved the data replication latency. All new data is replicating, and we are working to confirm data integrity for the time during which the issue occurred. We will provide another update within two hours.
Posted Apr 13, 2026 - 16:40 CDT

Investigating

We have identified a delay in data replication, and we are are working to address it as a high priority. We will provide an update by 5pm CDT.
Posted Apr 13, 2026 - 15:02 CDT
This incident affected: Snapsheet Claims (US).