US UAT Data Replication Delay

Incident Report for Snapsheet

Resolved

The delay in US UAT data replication has been resolved, and performance and returned to normal levels.
Posted Jun 18, 2026 - 06:26 CDT

Update

We are continuing to progress on the fix for the issue and performance is improving. We will provide another update by 9am central.
Posted Jun 17, 2026 - 21:21 CDT

Identified

We are experiencing a delay in US UAT data replication of approximately 2.5 hours. We are actively working on resolving the issue and will provide another update within 2 hours.
Posted Jun 17, 2026 - 18:23 CDT
This incident affected: Snapsheet Claims UAT (US).