Data Replication Delay - US Production

Incident Report for Snapsheet

Update

Please note that the data replication delay is only for history/audits tables in the US production environment. Other tables are replicating normally. We are continuing to investigate possible optimizations and will provide an update within 4 hours.
Posted Jul 23, 2026 - 12:31 CDT

Identified

We are experiencing data replication delays for history/audits tables in the US production environment. We have identified the cause and made enhancements to improve performance. The current ETA for resumption of normal replication speed is 18 - 24 hours, and we are continuing to work on further optimizations. We will provide an update within 4 hours.
Posted Jul 23, 2026 - 11:22 CDT
This incident affects: Snapsheet Claims (US).