US UAT Navigation bar Issue
Incident Report for Snapsheet
Resolved
This incident has been resolved. Please contact Snapsheet Support if you experience any further issues.
Posted Sep 19, 2024 - 10:15 CDT
Update
We are continuing to investigate the issue and will provide an update as soon as possible.
Posted Sep 19, 2024 - 09:57 CDT
Investigating
“We are investigating an issue with the navigation bar in US UAT and will provide an update as soon as possible”
Posted Sep 19, 2024 - 08:51 CDT
This incident affected: Snapsheet Claims UAT (US).