Increased SMS Error Rates

Incident Report for Snapsheet

Resolved

This incident has been resolved.
Posted Aug 17, 2023 - 21:52 CDT

Monitoring

Our vendor has reported an issue and is currently seeing elevated error rates, causing SMS delivery delays. We will continue to monitor the issue and provide updates as they become available.
Posted Aug 17, 2023 - 19:38 CDT
This incident affected: Snapsheet Payments (US), Snapsheet Claims (US, EU), and Snapsheet Appraisal Services (US, EU).