Data Reconciliation

Incident Report for Snapsheet

Update

We are continuing to address the data inconsistencies. We will provide another update at 5pm CDT.
Posted Apr 14, 2026 - 14:03 CDT

Identified

We have identified some remaining data inconsistencies from the replication delay experienced on April 13. We are working to address the issue with an ETR of end of business today. We will provide another update by 2pm CDT today.
Posted Apr 14, 2026 - 09:38 CDT
This incident affects: Snapsheet Claims (US).