Sendgrid Email Deferment Impacting Some Microsoft Office Users

Incident Report for Snapsheet

Identified

We have identified the issue that is causing delayed email deliveries to some recipients with Microsoft associated inboxes. We are seeing some improved performance, but we are continuing to work with Sendgrid to fully resolve the issue. We will provide another update by 10am CST tomorrow.
Posted Feb 25, 2026 - 15:59 CST

Update

We have engaged Sendgrid to remediate the issue that is causing the delays in email deliveries. The next update will be no later than 4pm CST.
Posted Feb 25, 2026 - 12:40 CST

Investigating

We have observed an issue with Sendgrid that is causing some customers to experience degraded performance of Microsoft Outlook. This issue is resulting in pending deliveries of some emails from Snapsheet to the impacted Microsoft accounts.
Posted Feb 25, 2026 - 11:39 CST
This incident affects: Snapsheet Claims (US).