Search Indexing Delay

Incident Report for Snapsheet

Resolved

We have resolved the delay in search indexing and confirmed searches are performing normally.
Posted Feb 23, 2026 - 18:13 CST

Investigating

There is currently a delay in search indexing that is causing a delay in claims or policies becoming searchable. We are aware of the issue and working to address it as a high priority.
Posted Feb 23, 2026 - 16:37 CST
This incident affected: Snapsheet Claims (US).