Twilio SMS Incident
Incident Report for Snapsheet
Resolved
Twilio Reported: All services impacted by the issues with the Twilio Rest API have recovered and are operating as intended. This incident has been resolved.
Posted Feb 14, 2024 - 16:31 CST
Update
Twilio: We're seeing recovery in the Twilio Rest API, impacting multiple Twilio services.

We will be monitoring all services to ensure a full recovery and provide another update in 30 minutes or as soon as more information becomes available.
Posted Feb 14, 2024 - 15:59 CST
Monitoring
Twilio reported that they have identified and are working to fix an issue around SMS. We are monitoring the incident on our end and will post any updates here.

Twilio Service Status: https://status.twilio.com/
Posted Feb 14, 2024 - 15:42 CST
This incident affected: Snapsheet Claims (US, EU).