Metrics Showing Internal Error
Incident Report for Snapsheet
Resolved
This incident has been resolved.
Posted Jun 17, 2024 - 10:02 CDT
Update
Incident Resolved
Posted Jun 17, 2024 - 10:00 CDT
Investigating
We are currently experiencing an issue resulting in metrics dashboards not loading. We are investigating and will provide another update as soon as possible.
Posted Jun 17, 2024 - 09:34 CDT
This incident affected: Snapsheet Claims (US).