Data Latency Delay

Incident Report for Snapsheet

Resolved

Data replication latency has returned to normal levels. We will review the incident and follow up with a post-mortem within the next business week. Please contact the Snapsheet support team if you experience any further issues.
Posted May 07, 2026 - 15:51 CDT

Identified

We are currently experiencing data replication latency in the production environment. We are aware of the issue and working to improve performance. We will provide another update within the next two hours.
Posted May 07, 2026 - 14:10 CDT
This incident affected: Snapsheet Claims (US).