UAT Environment Outage

Incident Report for Snapsheet

Resolved

This incident has been resolved and access restored. Please reach out to Snapsheet Support with any further questions or concerns.
Posted Jun 10, 2026 - 16:57 CDT

Investigating

We have identified an issue within the UAT environment that is impacting user access. We are investigating the issue as a high priority and will provide an update within one hour.
Posted Jun 10, 2026 - 16:34 CDT
This incident affected: Snapsheet Claims UAT (US).